【Docker】atmoz/sftp权限报错remote readdir(“/sftp”): Permission denied解决

最近从黑群晖换到了飞牛OS,由于飞牛目前不支持sftp,因此只能用docker镜像atmoz/sftp部署容器来解决,部署命令如下:

sudo docker run \
 -d \
 --name atmoz-sftp-server \
 --restart=unless-stopped \
 --privileged=true \
 -p 2222:22 \
 -v /data/docker/atmoz/upload:/home/foo/sftp \
 atmoz/sftp foo:pass:1001

其中的挂载目录,端口,用户名密码登根据自己个人情况设定,注意用户名foo和容器内目录foo要对应。

部署成功后,使用sftp命令连接(sftp -P 2222 foo@atmoz-sftp-server-ip)上会报错remote readdir(“/sftp”): Permission denied,alist挂载后页面也会报错failed get objs: failed to list objs: open /volume2/disk1: permission denied

解决办法:

使用bin/bash进入容器内部,进入到相关目录,然后执行下列命令,把foo加入root用户组

 chown -R foo:root /sftp

暂无评论

发送评论 编辑评论


|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇