最近从黑群晖换到了飞牛OS,由于飞牛目前不支持sftp,因此只能用docker镜像atmoz/sftp部署容器来解决,部署命令如下:
sudo docker run \
-d \
--name atmoz-sftp-server \
--restart=unless-stopped \
--privileged=true \
-p 2222:22 \
-v /data/docker/atmoz/upload:/home/foo/sftp \
atmoz/sftp foo:pass:1001
其中的挂载目录,端口,用户名密码登根据自己个人情况设定,注意用户名foo和容器内目录foo要对应。
部署成功后,使用sftp命令连接(sftp -P 2222 foo@atmoz-sftp-server-ip)上会报错remote readdir(“/sftp”): Permission denied,alist挂载后页面也会报错failed get objs: failed to list objs: open /volume2/disk1: permission denied
解决办法:
使用bin/bash进入容器内部,进入到相关目录,然后执行下列命令,把foo加入root用户组
chown -R foo:root /sftp